
Optical sampling techniques, such as underwater still pho-
tography and video recording, have seen rapid progress during
the past three decades, providing a wealth of information that
promises to reveal hidden facts marine scientists need to
understand the systems they are studying (Solan et al. 2003).
Recent developments and improvements in computer-based
image analysis methods make these techniques available to a

wider spectrum of study designs. The increasing volume of
marine digital images calls for rapid and efficient processing
methods to extract relevant, ecological information. The new
technique presented in this article will help to increase effi-
ciency (considerable time saving) in analysis of benthic hard-
bottom photographs with no or minor loss in accuracy. We
provide an example of a semiautomated image analysis using
the software package Adobe Photoshop and the “Fovea Pro”
plug-in (Russ 2001; Russ 2002).

Underwater photographical sampling has many advantages
compared with conventional marine sampling methods: Pho-
tographs can be stored for practically unlimited time and can
be re-examined whenever necessary. A much larger amount of
data can be collected during the same period; a fact that is
beneficial considering limited time and costs for marine field
activities. An important feature is the nondestructive charac-
ter of the method, which is a prerequisite to preserve speci-
mens for subsequent taxonomic analysis (Baguley et al. 2004).
It gives the scientist the opportunity to monitor the same sam-
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Abstract
Benthic rocky bottom studies often investigate community structure and function where estimates of per-

centage cover and abundance of epibenthic organisms are required. Nondestructive photographic methods have
the advantage of preserving benthic communities for repeated sampling. There is a need to accelerate image pro-
cessing to make sample analysis more cost efficient and to make the data available in a timely manner. A semi-
automated procedure to estimate epibenthic cover and abundance using Adobe Photoshop and the image analy-
sis plug-in Fovea Pro was developed to meet this need. The method improves upon previous techniques by using
color-based automated selection tools and a species-coding system. The technique required some manual pro-
cessing because some species were less suitable for color recognition and the photographs were of inconsistent
quality. The semiautomated selection of colony-forming organisms was validated by comparing it to a strictly
manual approach using a data set from Balsfjord/northern Norway. Constrained ordination and Procrustes analy-
ses showed that the automatic and manual methods were equally effective at documenting variation in the
species/abundance data along the driving ecological gradient of depth. The minor deviations in species abun-
dance estimation between the two methods (mostly <20%) were unrelated to the depth gradient and thus had
negligible influence on the main ecological conclusions of the study. The semiautomated method is up to four
times faster than the manual approach, has clear advantages over former benthic image analysis methods, and
is well suited for detection of systematic biological patterns like ecological gradients.
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pling locations non-intrusively over time and eliminates con-
founding effects like trawl and grab sampling when investi-
gating long-term changes in benthic habitats (Kollmann and
Stachowitsch 2001). Benthic time-series studies using imaging
techniques may focus on recruitment and succession (Beuchel
and Gulliksen 2008; Pech et al. 2002; Stanwellsmith and
Barnes 1997), megafaunal activity (Smith et al. 1993), climate
variations (Beuchel et al. 2006), and population dynamics of
selected species (Fujita and Ohta 1988; Tyler et al. 1993).

There are also important drawbacks of image-based sam-
pling techniques. There are obvious limitations in quantita-
tive accuracy of the obtained image data, and in reliable
species identification. For this reason, photographs were, until
recently, mostly regarded as precursor or complementary to
conventional sampling techniques, or to make conventional
survey techniques more effective and to improve the sampling
design (Rumohr 1995). New advances in digital photography
offer greater opportunities in underwater photography with
the challenge being the development of more efficient ways
for data extraction, analysis, storage, visualization, and pro-
cessing (Solan et al. 2003).

Photographic techniques have already been used in a vari-
ety of benthic studies (e.g., Gutt et al. 1999; Gutt et al. 1996;
Jørgensen and Gulliksen 2001; Pech et al. 2004; Piepenburg
and Schmid 1997) where the main goal of image analysis was
to extract information about covered areas or counting data of
classified features in the picture. Volume and biomass estima-
tions have also been conducted using photo images (Abdo et
al. 2006; Baguley et al. 2004). Techniques involving color,
edge contrast, or sharpness correction of the whole image or
parts of it have been applied to improve data extraction and
reduce processing time (Andresen 2003; Dahab et al. 2004;
Taylor 2003b). Semiautomated and automated techniques
have also been developed and improved to accelerate the ana-
lyzing process. The key here was to automate as many of the
recurring tasks as possible, especially when large numbers of
pictures should be analyzed (Taylor 2003a). One strategy was
the automatic recognition of surfaces (Baguley et al. 2004) or
landscape patterns (Teixido et al. 2002) that can be related to
species or community characteristics. Another approach was
the application of point-sampling methods by superimposing
grids on the image and subsequent quantification of objects at
the intersections of the gridlines (Gatlin et al. 1993; Roberts et
al. 1994). Automatic separation of areas with the same or sim-
ilar colors from neighboring areas, often referred to as color
segmentation techniques, has also been attempted (Bernhardt
and Griffing 2001; Borsotti et al. 1998; Gerald et al. 2001;
Gerasimov 2000; Thornbush and Viles 2004).

Underwater photography is a useful, “nondestructive”
method for obtaining information on conspicuous epifaunal
organisms. Photographs of permanently marked areas over
long time periods give the opportunity to study population
dynamics (e.g., settlement, age, and mortality), individual
growth and productivity, competition for space, predation,

and community succession. We present a novel technique,
which efficiently retrieves data on abundance and percentage
cover from photographs of epibenthic organisms using Adobe
PhotoShop CS (APS) and Fovea Pro. The described method has
already been successfully applied in monitoring long-term
changes in benthic community development on permanent
sites at northern Norwegian and Svalbard coasts (Beuchel and
Gulliksen 2008; Beuchel et al. 2006). Here we describe a way
to optimize this method with a significant reduction in the
amount of time needed for image analysis.

The purpose of the study is to compare two methods in
selecting and extracting data of benthic organisms: one strict
manual approach and one using automatic and semiautomatic
selection tools based on color recognition. In our assessment,
we test the two methods on photographs of colony-forming
organisms, such as sponges and crustose algae, taken along a
depth gradient. Our hypothesis is that the automated method
would perform as well as the manual in detecting patterns of
benthic community structure along an environmental gradient.
Further, we address the question to which degree the automatic
selection techniques work successfully across multiple images,
and if the time savings are dependent on image quality.

Materials and procedures
Collection of photographs—The underwater photographs were

collected by scuba diving, based on a technique developed by
Tomas Lundälv (Lundälv 1971; Torlegard and Lundälv 1974).

The camera was a Hasselblad Super Wide Camera (SWC)
with a Biogon 38 mm lens in a Hasselblad underwater casing
fitted with a corrective glass port (including electronic
flashes). The camera system was mounted onto a 0.5×0.5 m
(0.25 m2) metal frame enclosing the photographed bottom
area to obtain quantitative data of abundance and percentage
cover of bottom organisms.

Image processing—Conventional photographs based on pos-
itive reflectives or transparencies (slides), digital images, or
digital still images extracted from video recordings using video
capture equipment can be used for image analysis. In this
study, slides were digitized using a flatbed scanner (Epson Per-
fection 3200 Photoscan) with a resolution of 1200 dpi. The
obtained images were stored in TIFF format.

Measurements on the images were carried out in Adobe Pho-
toshop CS (APS) and the commercial software extension of Fovea
Pro v4.0 (Russ 2001; Russ 2002), using an Apple Power Mac G5.
With the Fovea Pro plug-in installed, the interactive slide bar of
APS filters is extended (Fig. 1) providing a variety of additional
features. Combined with Photoshop Actions and Script capabil-
ities, the plug-in can be used to automatically process folders
containing batches of images, yielding data files ready for further
interpretation in spreadsheet or statistics programs.

Before processing, the image format was converted to RGB
(Red Green Blue), because most filters in Fovea Pro work only
in RGB mode (Image → Mode → RGB Color). Then a copy of
the background layer with the original image was made,
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which remained untouched during all further processing
(Layer → Duplicate Layer) (Table 1). The next step was to cre-
ate an image that contains the area inside the metal frame
using the crop-tool from the tools palette (Fig. 1). Now, the
image could be calibrated to its original size of 50 × 50cm
(Filter → IP•Measure Global → Calibrate Magnification), so
that all subsequent measurements referred to the size in situ.

Light and color distribution on the picture were adjusted to
obtain consistent images suitable to apply the automated
color sampling tools. Full automatic correction tools like
“Auto levels” or “Auto color” yielded good results and were
least time consuming (Image → Auto levels/Auto color). Due
to the use of a flash, some areas were particularly over- or
underexposed. Those areas were improved using the “Gradi-
ent tool” (tool palette) or the “Shadow/Highlight” filter

(Image → Adjustments → Shadow/Highlight). Their use was
more laborious than just the application of automatic tools.

There were many recurring steps during image processing
and analysis (copying and deleting layers, color and light
adjustments, assigning RGB codes to species, etc.). To auto-
mate and speed up the workflow, “action files” (Photoshop
macros) were created using the Action palette. An action file is
a series of commands that can be recorded at a certain time
and “played” later. The macros contained breaks (pauses) that
halt the automated process and allow for manual adjustment
if needed (Fig. 1). During the initial stage of image processing,
the same sequence of commands was batch processed using
an “Action file” to increase time savings.

Image analysis—An essential step in the presented method
was the assignment of a specific color-code to each species or

Fig. 1. Screen picture showing image analysis in Adobe Photoshop with the extended toolbar of Fovea Pro. Some areas covered by benthic organisms
were already selected and filled with a color of a species-specific RGB code. Underexposed areas along edges and furrows are marked with black. Dif-
ferent layers were used for species selection, and repeating steps were executed automatically using Action files (window on the right border of screen).
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Table 1. Detailed instructions of Adobe Photoshop and Fovea Pro commands used in analysis of epibenthic organisms. The left col-
umn explains each step involved in measuring different types of organisms. The right column lists the commands to be executed and
differentiates between menus, toolbars, dialog boxes, and literal instructions. (Legend: Bold = main menu; Underline = Toolbar, tools;
Italics = Dialog box).

Steps and description Commands in Adobe Photoshop and Fovea Pro

Image processing:

Open image in Adobe Photoshop File → Open → select image file

Convert color mode to RGB Image → Mode → RGB color
(most filters in Fovea Pro work only in RGB)

Select area of inner frame = area of interest, Tool bar → Crop tool (outline area of interest) → check box Perspective �

correct for distortion from camera → fit crop area onto area of inner frame → press Return-button

Make a copy of layer with the area of interest, Layer → Duplicate Layer → label with “working layer”
label new layer as “working layer”

Adjustment of contrast and brightness Image → Auto levels, auto color; or Image → Adjustments
→ Brightness/Contrast, Shadows/Highlight

Tool bar → Gradient tool → Linear or radial gradient

Calibration of image, scale for measurements Filter → IP•Measure Global → Calibrate magnification → Select points on
upper right and left edges of image, set distance to known width of image
(in our pictures 50 cm)

Selection of species and bottom features:

Solitary organisms, small (only count data are desired): Layer → New layer → label with “small solitary organisms”
create new transparency layer for markers Tool bar → Brush tool, select diameter ~20 pixels → select species-specific

color (previously defined) from Swatch bar → mark each with a dot.

Solitary organisms, small (in addition to count, also length Tool bar → line tool, select diameter 1 pixel → select species-specific color
or diameter data are desired): (previously defined) from Swatch bar → mark each length or diameter

with a line.

Solitary organisms, big (count and covered area data are desired) Choose Layers window → select “working layer” → Toolbar →
and colony-forming organisms that cannot be automatically choose Lasso tool or Magnetic lasso tool (when organism has a distinctive
selected: edge to neighboring features) from tool bar → encircle organism → Layer

Manual selection of covered areas on “working layer,” → Layer via cut → label with “species name”
cut and transfer to a new layer

Colony-forming organisms that can be selected semiautomatically: Choose Layers window → select “working layer” → Select → Color range
Automatic selection of covered areas on “working layer” → Three alternatives:
by predefined or image-specific color range, smoothing selection (1) Load (if pre-defined.axt file)

to remove tiny areas, cut, and transfer to a new layer (2) define desired color range by additive sampling using the color picker (+)
(3) apply a combination of both, then → determine fuzziness (thresholds

the color range) → OK → Select → Modify → Smooth (3-5 pixels) →
OK → Layer → Layer via cut → label with “species name”

Shaded areas (due to use of flashlight, or in crevasses or furrows), Same procedure as for selecting colony-forming organisms
sediments, or unpopulated areas

Measurements:

Fill selected area with species-specific color (color code in RGB) Pick species-specific defined RGB color from Swatches bar, Edit → Fill →
Use: Foreground color, Mode: normal, Opacity: 100%, Preserve Transparency:
Yes → OK

Measure selected areas of organisms Filter → IP•Measure features → Measure regions

Reduce number of layers to keep file size small by combining layers Choose Layers window → Mark layers to be combined as ‘visible’ → Layers
for big, solitary, and all colony-forming organisms, respectively → Merge visible → label with, e.g., “colony-forming organisms,”

repeat steps for other groups

Save file File → Save as → Select folder and name the file



taxon using the RGB model of APS. Each color channel of red,
green, and blue encompasses values between 0 and 255 in the
8-bit color space, which results in a total number of 2553 dif-
ferent colors. Before image analysis, a 9-digit color-code (con-
taining the R, G, and B channel values) was created for each
species or taxon and stored in a swatch-palette of Photoshop.
First, the covered areas of a species in the image were selected,
and then these areas were copied to a new layer and filled with
the respective RGB-coding color using the macro procedure in
APS. The color codes appeared along with the actual mea-
surements in the results table and worked as identifiers for the
respective species.

“Action files” were also used during image analysis, but
unlike their use in image processing, no batch processing was
applied. Each image was treated separately while running the
“Action file.” Recurring tasks were carried out automatically
while the script stopped for manual work to be conducted.

During the analysis, we distinguished between solitary and
colony-forming organisms. The relevant ecological data, like
total abundance (counts) for solitary organisms and the area

covered by colonial organisms (and large solitary species),
were retrieved by applying different measuring instruments
from the tools palette.

For the selection of solitary organisms with a radial form
(e.g., actinarians, sea urchins, some solitary ascidians), the cir-
cle/ellipse marquees from the tools palette were used. Smaller
motile organisms (e.g., chitons) or organisms with a very com-
plex structure (e.g., sea stars) were marked with dots or
straight lines. The measurements from such selections were
the bases for analysis of, e.g., size distribution, age determina-
tion, and growth/production.

Two different methods were applied for the selection and
quantification of colony-forming epifauna and macroalgae
(Fig. 2). The methods differ in accuracy and efficiency and were
compared in detail in the assessment study of this article. Dur-
ing the manual method, colonial taxa and bottom features
were selected by surrounding their covered area using the
“Lasso tool” and the “Polygonal lasso tool” from the tools
palette. In addition, the “Magnetic lasso tool” was applied for
faster selection of complex objects set against a high contrast
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Fig. 2. Comparison of selection methods of colony forming benthic species from the same original picture using (A) the manual and (B) the semiau-
tomated selection method.



background (Fig. 2). The selected areas of each taxon were then
transferred to a new layer (Layer → Layer via cut) and filled
with the assigned RGB-color for that feature (species or taxon).

The semiautomated method was applied to groups like
sponges, ascidians, and calcareous algae that often showed an
almost consistent surface and color (Table 2, Fig. 2). These
characteristics made those taxons favorable for a color-based
selection without tracing its outline (Select → Color range).
The color-based selections were refined by additive and/or
subtractive sampling and by limiting or expanding the color
range. The color range of a specific taxon is defined by its RGB
start and tolerance values that were stored in an “Action” file
for use in multiple images. Another tool used for color-based
selection was the “Magic wand tool,” which works on similar
principles as “Color range.” In most cases, the full automatic
“Color range” and “Magic wand tool” needed some manual
touch-up to obtain satisfying selections.

Areas not inhabited by any organisms were also measured
to quantify the entire area within the frame. Such areas could
be sediment deposits or bare rock. Solitary organisms that had
more than half of their body surface outside the frame were
also measured, but later omitted from the total area.

In some cases, the quality of the underexposed parts of the
image could not be improved and thus no useful information
could be retrieved. Those areas were quantified as “shaded
areas” and subtracted from the total area of the image. They
were often found along the image borders due to shading
effects from the metal frame. Deeper furrows in the bedrock
posed a similar challenge as well as large stones and organisms
(Fig. 1). Shaded areas were successfully extracted using color
range functions (Table 2)

For the calculation of abundances, we used different com-
munity layers to correct for errors due to the top-down view
of the camera system. To simplify the calculation, we distin-
guished between three community layers: (1) large, erect
brown algae, (2) large, solitary organisms like sea anemones
and sea urchins, and (3) all small solitary organisms and
encrusting colonial organisms close to the rock surface.

The output data were in simple text format and could eas-
ily be imported into a spreadsheet. Each row in the file con-
sisted of data from a single measurement (a solitary organism,
a single colony, or an abiotic feature). The data file contains
parameters such as diameter, the covered area, the perimeter,
and the position (coordinates) of an organism within the

Table 2. Common groups of epibenthic organisms and the applied method of image analysis in Adobe Photoshop and Fovea Pro.

Species/taxon, RGB Tolerance Degree
bottom feature Method* start values† level† of automation‡ Comments

Shaded areas SA 0.0.0. 15–20 5

Hildenbrandia sp. SA 90.90.75 20–30 3

Calcareous algae, SA 230.210.200 20–30 4-5 Some manual touch up necessary
because of variations in color

Lithothamnium sp.

Calcareous algae, SA 200.160.130 25–40 3
Phymatholithon sp.

Phæophycea SA 100.100.70 20–30 4 Start values resemble Hildenbrandia sp.,
the areas of both species should be
analyzed separately.

Porifera, colony-forming SA Start values differ Dependent from 3 Some manual touch-up necessary
ascidians due to large variations inner-species variation because of variations in color

within same species

Hydrozoans, Bryozoans SA Start values differ Dependent from 1-2 Considerable manual work is necessary
due to large variations inner-species variation in most of cases

within group

Gastropods, bivalves M N/A N/A 0 Often complex structure or burrowers,
outlined manually or marked with dots

Sea urchins, sea stars, M N/A N/A 0 Often complex structure, outlined
brittle stars, sea cucumbers manually, or marked with dots

*SA = semiautomated method, M = Manual method.
†RGB start values and the tolerance level refer to initial values of the color range selection tool in Adobe Photoshop.
‡Degree of automation: 0 = automation impossible, 1 = automation very limited, mostly manual outline, 2 = some automation, manual outline > 50%,
3 = automatic and manual selection approximately equal, 4 = high proportion of selection automated, minor manual touch-up, 5 = excellent automatic
selection, occasionally manual touch-up.
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square. The semiautomated color sampling resulted in a large
number of very small areas of only few pixels. Such areas were
efficiently removed by smoothing the selection (Select →
Modify → smooth → 3-5 pixels).

Assessment
Photographs for this study are from a near vertical transect

along a steep rock wall that extends from the surface down to
about 100 m at Haugbergnes, Balsfjord, northern Norway
(69°31′09′(N; 19°00′30′(E). Photographs were taken in October
1991 from 2 to 44 m depth, in depth intervals of 2 m. For this
assessment, we selected 10 pictures from different depths
along the transect with a high amount of colony-forming
organisms to compare the two different methods of image
analysis.

Statistical analysis—To compare the information obtained
by manual versus automatic image-processing techniques, we
used ordination methods followed by Procrustean analysis, so
as to assess the similarity between the two data sets (Legendre
and Legendre 1998; Peres-Neto and Jackson 2001). We first
summarized the benthos data by indirect ordination (Corre-
spondence Analysis [CA]) on the combined manual and auto-
mated data, to inspect the deviations between paired (manual
and automated) observations in the reduced ordination space
represented by a biplot (Greenacre 2007). Second, we per-
formed two separate CAs, one for each data set, to obtain ordi-
nation matrices that could be compared by Procrustean analy-
sis. To obtain a measure of discrepancy between ordination
results, we applied a Procrustean superimposition (Peres-Neto
and Jackson 2001). The measure of discrepancy could then be
tested for randomness by permutation. The same sequence of
ordination and Procrustean analysis was thereafter performed
using Canonical (Constrained) Correspondence Analysis
(CCA), a direct ordination technique (Greenacre 2007; Ter
Braak 1987). Constrained ordination was first applied on the
combined data set, with depth and analyzing method (includ-
ing their interaction) as explanatory variables. Thereafter, sep-
arate CCAs were applied to the two data sets, using depth as
explanatory variable, followed by Procrustean analysis of the
constrained ordination results. The rationale behind an analy-
sis of discrepancy between data sets in the constrained ordi-
nation space is that by focusing on the main ecological gradi-
ents, we could identify deviations between data sets that are
relevant for ecological interpretation.

Spatial distribution—In the assessment of our semiauto-
mated method, 11 different colony-forming benthic taxa were
detected and analyzed. In addition, areas that were shaded
due to use of flash were also estimated using both semiauto-
mated and manual method (Fig. 3).

The two taxa of bottom-covering algae (Hildenbrandia sp.
and calcareous red algae) were mostly found in the upper
depths. Calcareous red algae showed a continuously decreas-
ing abundance from 14 m (covering ≈50% of the total area) to
34 m (<5%). Five different taxa of sponges were detected, of

which two could be identified to genus level. They occurred
mostly in middle and lower depths. Halichondria sp. showed
highest densities at depths between 24 and 32 m, covering up
to 10% of the total area. Porifera indet.2 was the most abun-
dant sponge, covering up to 30% of the photographs at depths
between 34 and 44 m. Bryozoans were found across the entire
depth transect, with increasing abundances below 28 m. Two
taxa of ascidians (Botryllus sp. and Didemnum sp.) were found
at the lowermost depth (44 m) and occurred in low densities.

Differences between manual and semiautomated method—
There were no systematic differences in estimation of covered
area between the manual and the semiautomated method
(Fig. 3). The deviations were both positive and negative for
most of the taxa at different depths. Calcareous algae, how-
ever, tended to be underestimated (maximum 22% at 24 m) by
the automated method, whereas bryozoans and ascidians were
often overestimated (highest values 26% for bryozoans at 34
m and 17% for Didemnum sp. at 44 m). The differences
between the manual and semiautomated method were in
most cases < 20% (in 78.7% of measurements, n = 47 and
>30% in only 2.13% of all measurements [Fig. 4]).

The deviations seen in the CA between the manual and
semiautomated method were very low. Axis CA1 accounted
for about 55% of the observed variation and showed clearly a
gradient related to depth. Axis CA2 accounted for 18% of the
observed variation (Table 3). In the CCA, the inertia of the
constrained axes (0.498) made up almost half of the total iner-
tia of all axes (1.094, Table 3). The main gradient (CCA1) was
very closely associated with depth (Fig. 5) where most of the
species and depth intervals were grouped along this axis.
Species associated with upper depths (euphotic zone) were
Hildenbrandia sp., calcareous red algae, and Bryozoans 2,
whereas different types of sponge and the ascidia Didemnum
sp. were more related to lower depths. The inertia of the depth
gradient (0.494) accounted for almost all the constrained vari-
ation in the benthic community, whereas the differences
between the manual and semiautomated methods that are
close related to CCA2 (inertia = 0.003) were negligible (Table
3). In the Procrustes analysis, the Procrustes errors based on
CCA are low (0.164) and the correlation factor between the
two Procrustes matrices is very high (0.993) (Table 3). The
deviations between manually and semiautomatically
processed pictures are predominantly orthogonal to CCA1
and the depth gradient (Fig. 6).

Discussion
The benthic community at Haugbergnes is clearly struc-

tured along a depth gradient. Almost all variation in the CCA
was related to this axis (Table 3, Fig. 5). In close vicinity to our
location, a strong depth gradient structuring the benthic com-
munity was found by Jørgensen (2001) when a similar range
of depths was investigated using a diver-operated suction sam-
pler. Comparable with our results, algae dominated at 10 m
depth, whereas sponges and bryozoans were more abundant
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at 20 and 30 m depths. Filter-feeding rocky bottom taxa such
as poriferans, hydrozoans, bryozoans, and tunicates were asso-
ciated with vertical and overhanging sites. These taxa proba-
bly benefit from limited sediment action, which would clog
their feeding apparatus (Evans et al. 1980). Algae are poor
competitors with increasing depth due to the reduced amount
of light, which opens more space for animal settling (Sandnes
and Gulliksen 1980). Vertical walls are usually less favorable
for predators like sea urchins, so the community appears to be
structured mainly by competition for space among the organ-
isms (Sebens 1985).

The CCA showed that the differences in species abundance
estimation between manual and semiautomated processed
pictures were negligible and unrelated (orthogonal) to the
driving ecological gradient of depth (Fig. 5). Procrustes analy-

Fig. 3. Species distribution of benthic taxa at Haugbergnes. Black bars indicate the covered area (upper x axis) for each species at different depths,
obtained by the manual (M) and semiautomated (A) method. Percentage deviations between the two methods are given at each depth (lower x axis)
as gray bars (if positive deviation) and white bars (if negative deviation).

Fig. 4. Frequency of relative deviation between manual and semiauto-
mated treated pictures of cover of selected benthic taxa at Haugbergnes.
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ses confirmed this pattern showing that the paired deviations
between the two methods were also predominantly orthogo-
nal to the depth gradient. They, therefore, did not influence
the main ecological result (i.e., the importance of the depth
gradient), and would thereby not constitute a serious limita-
tion of the automated method. Thus, the main conclusions
about an environmental gradient structuring the benthic
community was not affected from differences between the two
methods, whereas the amount of time needed for processing
and analyzing the images decreased considerably with the
semiautomated method.

Comments and recommendations
Many techniques in estimating cover and abundance of

epibenthic organisms based on imaging techniques (e.g.,
Rumohr 1995) are described as elaborate and time-consuming.

Our new approach using APS and Fovea Pro is an improve-
ment over previous methods. It significantly reduces the for-
mer efforts needed to manually outline and measure complex
structures of rocky bottom ecosystems of combining semiau-
tomatic and manual techniques. The method meets the chal-
lenge in combining efficiency with the accuracy that is
required in modern ecosystem analysis. We suggest that APS
and Fovea Pro provide a valuable alternative to expensive cus-
tom-made image analysis systems for many applications in
benthic-ecological investigations.

The semiautomated estimates of cover of colonial ben-
thic organisms and macroalgae are not unreasonably differ-
ent from direct measurements, since differences between
those estimates were mostly below 20%, with deviations
randomly distributed in both positive and negative direc-
tions (Fig. 3). However, there were considerable time savings

Table 3. Results of ordination and procrustes analysis for the benthic community at Haugbergnes.

Total Inertia-unconstrained Inertia-constrained Eigenvalues
Analysis inertia axis axis Axis 1 Axis 2

CA 1.094 1.094 0.553 0.187
CCA 1.094 0.596 0.498 0.494* 0.003*

Root mean Correlation in symmetric
Sum of squares squared error Procrustes rotation Significance

Procrustes analyses 0.268 0.164 0.993 <0.001†

based on CCA

*Constrained axis
†Based on 1000 permutations

Fig. 5. Triplot of CCA results, including taxa, samples, and constrained
factors depth and method (Manual).

Fig. 6. Procrustes analysis based on CCA results showing deviations
between manual and semiautomated methods.
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applying the new method: The amount of time used for
image processing and analysis decreased from approxi-
mately 1 h using the manual approach to between 15 and
30 min (based on image quality and amount of organisms
that could be extracted automatically). This corresponds to
50% to 75% time saving for a skilled person. These estimates
were derived from this, as well as earlier studies where the
same technique was used (see Beuchel and Gulliksen 2008;
Beuchel et al. 2006). The new approach of using automatic
processes of color segmentation for a number of colony-
forming species yielded good results (Table 2). The method
was excellent when applied to species with distinct and con-
sistent colors, like calcareous red algae (e.g., Lithothamnium
sp.), brown algae, and some species of sponges and colony-
forming ascidians (e.g., Didemnum sp.). It also worked suffi-
ciently on bryozoans and hydrozoans, but the pre-process-
ing of the images including adjustments of illumination,
color, and contrast was assessed to be essential to improve
the accuracy of semiautomatic color segmentation (Bern-
hardt and Griffing 2001). Another benefit of our method is
the permanent and easily accessible photographic record of
each bottom organism or feature. Those are cross-referenced
to data sheets via the RGB coding system, and thus, offer the
possibility for later re-examination. Furthermore, the tech-
nique is nondestructive, which provides great opportunities
for monitoring the same bottom locations over long time
without physically changing the benthic communities. The
semiautomated method can also be applied to other benthic
habitats to estimate cover and abundance, especially when
there is a distinctive difference in color and structure
between the taxa. A vast proportion of the benthic imagery
is collected with video. We have tried to apply our tech-
nique to video imagery, with some promising results (no
data available). Higher resolution (high definition) and
slower movement of the camera system yielded better
results, but the outcomes are still below the quality of still
images. Since 2005, the same technique has been applied to
digital still pictures, with a doubling of the resolution com-
pared with the presented method based on scanned slides.
Much smaller individuals could now be recognized, and
species determination has been improved.

There have been some drawbacks of the semiautomated
method that can be improved in the future. The sampling
based on color range worked well in uniformly exposed and
high contrast photographs, but became more labor-intensive
in pictures with severe shaded or underexposed areas. In addi-
tion, color and morphological variation within a species
could be large at small spatial scales. Those pictures needed
additional “touch-up” to the automated technique, using
manual tools (e.g., the lasso tool or magic wand tool) to
increase accuracy. Many species of sponge and ascidians
could not be reliably identified from photography. We rec-
ommend taking physical samples of epibenthic fauna from
nearby locations for identification in laboratory to overcome

this problem, but some uncertainty will always persist. In
many cases, identification from pictures must be made at a
higher taxonomic level.

In the future, a key issue will be the improvement of pho-
tographic techniques to increase the quality of the initial
image and to save time for image processing. It seems that
the skilled use of a flash has the potential for more equally
exposed photographs. Some tools to alter the exposure of the
whole or parts of the image were applied during the image
processing in APS, but those adjustments are limited and
cannot replace an original photograph of better quality. We
tried, e.g., the “gradient tool,” which delivered good results,
but its application is often tedious and time-consuming.
Another suggestion was to photograph the quadrates with
standard color tiles or black and white standards, as this
would help in the initial color correction and reduce image-
processing time. We used only few of the available filters of
APS and Fovea Pro in our study, but there are many possibil-
ities for further development of the method using these
tools. The aim should be to increase the amount of auto-
matic recognition including more species, but due to the
complexity of epibenthic hard bottom substrates, it is hard
to believe that fully automatic species recognition will ever
be achieved.
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